Subscription Manager Degraded Performance

Incident Report for Array

Resolved

This has been resolved and the Subscription Manager service is fully functional again
Posted Sep 12, 2025 - 09:48 EDT

Investigating

Subscription Manager is experiencing a brief period of degraded performance due to database maintenance
Posted Sep 12, 2025 - 09:29 EDT
This incident affected: Subscription Manager.