Investigating issue with our system

Incident Report for Array

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 11:21 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 27, 2026 - 11:20 EST

Update

We are continuing to investigate this issue.
Posted Jan 27, 2026 - 11:11 EST

Investigating

We have been notified of a potential issue and are investigating.
Posted Jan 27, 2026 - 10:51 EST
This incident affected: My Credit Manager, Identity Protect, Privacy Protect, Offers Engine, BuildCredit Account, Subscription Manager, Student Loan Aid, and Financial Links.