Product Delay

Incident Report for Array

Postmortem

On February 4, 2025, a degraded performance incident occurred due to an unexpected failure in a routine database indexing operation. Application access was briefly terminated in order to remediate and immediately restored with all systems returning to normal operation. Additional measures have been put in place to monitor, identify, and prevent a similar failure in the future.

Posted Feb 07, 2025 - 09:46 EST

Resolved

Service is back to normal.
Posted Feb 04, 2025 - 16:46 EST

Investigating

Array is currently experiencing a lag in product services. We are actively investigating this issue.
Posted Feb 04, 2025 - 16:33 EST
This incident affected: My Credit Manager, Identity Protect, Privacy Protect, Offers Engine, Build Credit Account, and Subscription Manager.