Slow Response Times for Alerts

Incident Report for Array

Resolved

This incident has been resolved.
Posted May 28, 2025 - 19:11 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 28, 2025 - 17:38 EDT

Investigating

We are currently investigating slow response times for identity and credit alerts
Posted May 28, 2025 - 14:07 EDT
This incident affected: My Credit Manager and Identity Protect.