Equifax Failed Response

Incident Report for Array

Resolved

Errors look to have resolved from the bureau. We are still monitoring, but this incident appears to have resolved.
Posted Jul 07, 2025 - 21:19 EDT

Investigating

Equifax is currently experiencing an outage that is affecting our credit report system.
Posted Jul 07, 2025 - 20:10 EDT
This incident affected: My Credit Manager and Offers Engine.