Investigating System Issue

Incident Report for Array

Resolved

our monitoring indicated a low-volume occurrence of delayed response times for a small number of report storage / retrieval requests, we investigated and remediated.
Posted Apr 02, 2026 - 11:44 EDT

Investigating

We have been notified of a potential issue and are investigating.
Posted Apr 02, 2026 - 11:16 EDT