Investigating Issues Affecting Multiple Products

Incident Report for Array

Resolved

Services are restored
Posted Jul 07, 2026 - 12:38 EDT

Update

We have restored services and are continuing to monitor for performance issues
Posted Jul 07, 2026 - 12:22 EDT

Monitoring

As of 11:30 am ET, services are being restored. We are monitoring service improvement
Posted Jul 07, 2026 - 11:39 EDT

Update

Services are being restored
Posted Jul 07, 2026 - 11:34 EDT

Update

We have identified the problem and are working to restore service
Posted Jul 07, 2026 - 11:04 EDT

Update

We are actively working to restore service and will provide additional updates as more information becomes available.
Posted Jul 07, 2026 - 10:54 EDT

Identified

We are actively working to restore service and will provide additional updates as more information becomes available.
Posted Jul 07, 2026 - 10:53 EDT

Update

Our investigation is ongoing. We are actively working to restore service and will provide additional updates as more information becomes available.
Posted Jul 07, 2026 - 10:42 EDT

Update

Our investigation is ongoing. We are actively working on the issue and will provide updates as more information becomes available.
Posted Jul 07, 2026 - 10:40 EDT

Update

We are continuing to investigate this issue.
Posted Jul 07, 2026 - 10:34 EDT

Update

We are investigating an issue affecting Array products and will update as appropriate.
Posted Jul 07, 2026 - 10:30 EDT

Update

We have been notified of a potential issue affecting White label sites and are investigating.
Posted Jul 07, 2026 - 10:28 EDT

Investigating

We have been notified of a potential issue affecting Whitelabel sites and are investigating.
Posted Jul 07, 2026 - 10:24 EDT
This incident affected: My Credit Manager, Identity Protect, Privacy Protect, Offers Engine, and Subscription Manager.