Potential issue affecting Array+ / My Financial Health Android Users

Incident Report for Array

Resolved

This issue has been resolved
Posted Aug 06, 2026 - 16:44 EDT

Identified

The Issue has been identified and a fix is being implemented.
Posted Aug 06, 2026 - 11:23 EDT

Update

We are continuing to investigate this issue affecting My Financial Health users.
Posted Aug 06, 2026 - 09:33 EDT

Update

We are continuing to investigate this issue affecting My Financial Health users.
Posted Aug 05, 2026 - 14:03 EDT

Update

We are continuing to investigate an issue that may be affecting My Financial Health users
Posted Aug 05, 2026 - 13:23 EDT

Update

We are continuing to investigate an issue that may be affection My Financial Health users on some Android devices. We will continue to update you.
Posted Aug 05, 2026 - 11:28 EDT

Investigating

We have been notified of a potential issue and are investigating.
Posted Aug 05, 2026 - 10:26 EDT
This incident affected: Array +.