TransUnion services have remained stable, and we are no longer seeing the service issues impacting enrollments, Score Simulator, and report ordering. This incident is now resolved.
Posted Sep 03, 2026 - 14:14 EDT
Monitoring
TransUnion services are showing signs of recovery, and we are seeing successful responses resume. We will continue to monitor closely to ensure services remain stable.
Posted Sep 03, 2026 - 12:45 EDT
Update
We are continuing to monitor the ongoing service disruption with TransUnion. This may impact enrollments, Score Simulator, and report ordering from the TransUnion bureau. We will provide another update as more information becomes available.
Posted Sep 03, 2026 - 12:12 EDT
Update
We are currently investigating an issue with TransUnion. This may impact enrollments, score simulator, and report ordering from this bureau.
Posted Sep 03, 2026 - 11:00 EDT
Investigating
We have been notified of a potential issue and are investigating.