Investigating Issue with Score Simulator

Incident Report for Array

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 16:48 EST

Update

We are continuing to investigate this issue.
Posted Jan 08, 2026 - 16:22 EST

Investigating

We have been notified of a potential issue with Score Simulator having loading issues for some clients.
Posted Jan 08, 2026 - 15:18 EST
This incident affected: My Credit Manager.