EFX Multiple Service Impact
Incident Report for Array
Resolved
This incident has been resolved.
Posted Dec 06, 2024 - 13:46 EST
Monitoring
EFX is currently experiencing an issue with one or more of their applications which is causing some service failure
Posted Dec 06, 2024 - 12:20 EST
This incident affected: My Credit Manager.