Service Disruption Due to Data Center Power Outage

Incident Report for Array

Resolved

All services have been restored.
Posted Jul 13, 2025 - 20:40 EDT

Update

Most services have been restored. We are completing restoring service after a disruption due to a power outage at a regional data center. We will provide updates as more information becomes available.
Posted Jul 13, 2025 - 20:34 EDT

Update

Partial services have been restored. We are continuing to restore services after a disruption due to a power outage at a regional data center. We will provide updates as more information becomes available.
Posted Jul 13, 2025 - 20:18 EDT

Update

Partial services have been restored. We are completing restoring service after a disruption due to a power outage at a regional data center. We will provide updates as more information becomes available.
Posted Jul 13, 2025 - 19:44 EDT

Monitoring

Partial services have been restored. We are completing restoring service after a disruption due to a power outage at a regional data center. We will provide updates as more information becomes available.
Posted Jul 13, 2025 - 19:24 EDT

Update

We are currently restoring service after a disruption due to a power outage at a regional data center. We will provide updates as more information becomes available.
Posted Jul 13, 2025 - 19:07 EDT

Identified

We are currently experiencing a service disruption due to a power outage at a regional data center. Our engineering team is actively working with our data center provider to restore services as quickly as possible. We will provide updates as more information becomes available.
Posted Jul 13, 2025 - 18:52 EDT

Investigating

We are currently experiencing a service disruption due to a power outage at a regional data center. Our engineering team is actively working with our data center provider to restore services as quickly as possible. We will provide updates as more information becomes available.
Posted Jul 13, 2025 - 18:25 EDT
This incident affected: My Credit Manager, Identity Protect, Offers Engine, Build Credit Account, and Subscription Manager.