Investigating System Issue

Incident Report for Array

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 23:30 EDT

Update

We are continuing to investigate this issue.
Posted Oct 13, 2025 - 21:40 EDT

Investigating

We have been notified of a potential issue and are currently investigating.
Posted Oct 13, 2025 - 20:46 EDT
This incident affected: My Credit Manager, Identity Protect, Privacy Protect, Offers Engine, Build Credit Account, Subscription Manager, and Student Loan Aid.