Bureau Degraded Performance

Incident Report for Array

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 23:15 EST

Update

We are continuing to investigate this issue.
Posted Feb 26, 2025 - 23:15 EST

Investigating

Equifax is experiencing degraded performance.
Posted Feb 26, 2025 - 23:05 EST
This incident affected: My Credit Manager, Identity Protect, and Offers Engine.