Investigating Financial Links Issue

Incident Report for Array

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 18:19 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 01, 2026 - 18:03 EDT

Update

We are investigating a potential issue affecting Financial Links.
Posted Apr 01, 2026 - 17:48 EDT

Investigating

We have been notified of a potential issue affecting Financial Links and are investigating.
Posted Apr 01, 2026 - 17:41 EDT
This incident affected: Financial Links.