Investigating System Issue with credit report pulls

Incident Report for Array

Resolved

This incident has been resolved. Report pulls for My Credit Manager were operational as of 11:45 am ET
Posted May 31, 2026 - 13:32 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 31, 2026 - 12:56 EDT

Identified

The issue has been identified and we are working towards a resolution
Posted May 31, 2026 - 11:03 EDT

Update

We have been notified of a potential issue and are investigating.
Posted May 31, 2026 - 08:36 EDT

Investigating

We have been notified of a potential issue and are investigating.
Posted May 31, 2026 - 07:58 EDT
This incident affected: My Credit Manager.