Micronotes Cross-Sell Issues

Incident Report for Array

Resolved

This incident has been resolved
Posted Aug 06, 2026 - 12:16 EDT

Update

We are still investigating an issue that is affecting customers using our Micronotes Cross-Sell services
Posted Aug 05, 2026 - 13:21 EDT

Update

We are currently experiencing an issue that is affecting customers using our Micronotes Cross-Sell services. We have identified the issue and are working toward a resolution. We expect an update by tomorrow (8/5)
Posted Aug 04, 2026 - 19:32 EDT

Identified

We have identified the issue and working on a fix
Posted Aug 04, 2026 - 14:20 EDT

Update

We are continuing to investigate this issue. We will update you shortly.
Posted Aug 04, 2026 - 12:57 EDT

Investigating

We have been notified of a potential issue and are investigating.
Posted Aug 04, 2026 - 12:27 EDT