Investigating Multiple System Issue

Incident Report for Array

Resolved

All systems have stabilized all services to a steady state volume.
Posted Mar 31, 2026 - 16:03 EDT

Update

We are currently investigating a potential issue that may impact Reporting, Privacy, and Identity services. During this time, you may experience degraded performance. Our team is actively working to identify the cause and will provide updates as more information becomes available.
Posted Mar 31, 2026 - 15:40 EDT

Update

We are continuing to investigate this issue.
Posted Mar 31, 2026 - 15:37 EDT

Investigating

We have been notified of a potential issue and are investigating.
Posted Mar 31, 2026 - 15:31 EDT
This incident affected: My Credit Manager, Identity Protect, Privacy Protect, Offers Engine, and Subscription Manager.