IDP Dark Web Monitoring Alert Delays

Incident Report for Array

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 16:44 EDT

Update

New IDP Dark Web Monitoring alerts are now being delivered, and we are processing the backlog of prior alerts.
Posted Sep 05, 2025 - 10:59 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 04, 2025 - 15:38 EDT

Identified

We are currently investigating an issue where IDP Dark Web Monitoring historical alerts are delayed.
Posted Sep 04, 2025 - 13:00 EDT
This incident affected: Identity Protect.