My Credit Manager & Private Label Service Degradation

Incident Report for Array

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 15:39 EDT

Update

We are continuing to investigate this issue.
Posted Aug 15, 2025 - 15:10 EDT

Update

You may be experiencing longer wait times for credit reports due to service issues, and you may be experiencing issues with your site domain.
Posted Aug 15, 2025 - 15:07 EDT

Update

We are experiencing a partial service outage for certain actions. These issues are currently being investigated.
Posted Aug 15, 2025 - 15:02 EDT

Investigating

Currently we are experiencing slightly slower than usual response times for some aspects of My Credit Manager. This is being looked into.
Posted Aug 15, 2025 - 14:58 EDT
This incident affected: My Credit Manager.