Investigating Identity Protect System Issue

Incident Report for Array

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 15:27 EDT

Update

We are continuing to investigate this issue with one of our vendors.
Posted Mar 10, 2026 - 14:07 EDT

Investigating

We are investigating degraded alert performance.
Posted Mar 10, 2026 - 13:26 EDT
This incident affected: Identity Protect.