We are investigating a system outage affecting Array services.

Incident Report for Array

Resolved

This incident has been resolved.
Posted May 21, 2026 - 16:19 EDT

Monitoring

Services are now recovering.
Posted May 21, 2026 - 16:16 EDT
This incident affected: My Credit Manager.