Investigating My Credit Manager System Issue

Incident Report for Array

Resolved

This issue has been resolved. We’re continuing to monitor performance to ensure everything remains stable.
Posted Apr 08, 2026 - 16:03 EDT

Investigating

We have been notified of a potential issue and are investigating.
Posted Apr 08, 2026 - 15:44 EDT
This incident affected: My Credit Manager.