Performance Update: We are currently experiencing a delay in publishing data to the Client Console reporting system. Our team is actively working on resolving the issue. Data will populate once this is resolved. Further updates will be available daily by 12:00 PM Eastern.

Investigating System Issue

Incident Report for Array

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 03:45 EST

Update

TUI is currently experiencing technical issues that may impact retrieval of some credit reports. We are actively investigating and will provide updates as available.
Posted Feb 04, 2026 - 00:37 EST

Investigating

We have been alerted to a potential issue affecting retrieval of some TUI credit reports and are currently investigating
Posted Feb 04, 2026 - 00:27 EST
This incident affected: My Credit Manager.