Issues with Equifax

Incident Report for Array

Resolved

Equifax has confirmed their incident has resolved. All services have been restored.
Posted Jun 12, 2025 - 22:43 EDT

Monitoring

We are actively monitoring the ongoing Google Cloud Platform outage. Equifax has reported that their services are affected, which may result in customer-facing errors. Services from other bureaus remain unaffected at this time
Posted Jun 12, 2025 - 17:48 EDT

Identified

Equifax is currently experiencing degraded performance. This is causing an increase in temporary errors and latency with some of our credit services.
Posted Jun 12, 2025 - 17:11 EDT
This incident affected: My Credit Manager and Offers Engine.