Array + Upgrade Services Issue

Incident Report for Array

Resolved

Updates have been posted and this issue has been resolved.
Posted Aug 18, 2025 - 14:55 EDT

Identified

The issue has been identified and a fix is being investigated.
Posted Aug 18, 2025 - 12:20 EDT

Investigating

We are currently investigating an issue where certain users are having issues with services on Array+
Posted Aug 18, 2025 - 11:38 EDT
This incident affected: My Credit Manager.