Investigating Financial Links Issue

Incident Report for Array

Resolved

The incident affecting Financial Links has been resolved.
Posted Dec 17, 2025 - 13:14 EST

Update

We are continuing to investigate an issue affecting Financial Links that may be causing a service interruption for some clients.
Posted Dec 17, 2025 - 13:10 EST

Update

We are currently investigating an issue with Financial Links that may be causing a service interruption for some clients.
Posted Dec 17, 2025 - 12:40 EST

Investigating

We have been notified of a potential issue with Financial Links and are investigating.
Posted Dec 17, 2025 - 12:32 EST
This incident affected: Financial Links.