MCM - Latency With Experian

Incident Report for Array

Resolved

This latency has been resolved
Posted Sep 23, 2025 - 13:06 EDT

Investigating

We are currently seeing an incident of high latency with Experian returns.
Posted Sep 23, 2025 - 12:43 EDT