Investigating System Issue

Incident Report for Array

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 17:38 EST

Update

We are currently investigating an issue with intermittent payment/enrollment failures
Posted Dec 05, 2025 - 17:10 EST

Investigating

We have been notified of a potential issue and are investigating.
Posted Dec 05, 2025 - 16:29 EST