Investigating System Issue

Incident Report for Array

Resolved

We have reached out to TU to confirm if any issues on their end & monitoring.
Posted Jul 02, 2026 - 20:23 EDT

Investigating

We have been notified of a potential issue and are investigating.
Posted Jul 02, 2026 - 17:58 EDT