Investigating System Issues Affecting MCM, IDP, and White Label Sites

Incident Report for Array

Resolved

Service performance has remained stable, and we have not observed a recurrence of the previously reported impact to Identity Protection (IDP) and My Credit Manager (MCM) alerts following the mitigation efforts implemented earlier.

At this time, we are considering the incident resolved. Our teams will continue to monitor the affected services to confirm continued stability. We appreciate your patience and understanding throughout this incident.
Posted Jun 02, 2026 - 12:27 EDT

Update

The affected services continue to operate without a recurrence of the earlier level of impact following the mitigation efforts implemented yesterday.

We remain focused on investigating the underlying cause and do not yet consider the issue fully resolved. Additional updates will be provided as warranted.
Posted Jun 02, 2026 - 10:01 EDT

Update

System performance remains stable following the mitigation efforts implemented earlier today. Our teams continue to validate the effectiveness of those efforts while monitoring for any recurring impact to Identity Protection (IDP) and My Credit Manager (MCM) alerts.

Although the observed impact has been reduced, we are continuing our investigation and do not yet consider the issue fully resolved. Additional updates will be provided as warranted.
Posted Jun 01, 2026 - 18:01 EDT

Update

We are closely monitoring the alert services following the latest mitigation efforts and are seeing improved stability across affected systems.

While service performance has improved, we are not yet considering the issue fully resolved. Our teams remain actively engaged as we continue to validate the mitigation and monitor for any recurring impact. Additional updates will be provided as new information becomes available.
Posted Jun 01, 2026 - 15:49 EDT

Update

We are actively analyzing the issue affecting My Credit Manager (MCM), Identity Protection (IDP), and White Label sites.

The impact remains limited to intermittent disruptions affecting Identity Protection and Credit alerts. Our teams are working to restore full service and will share further updates as they become available.
Posted Jun 01, 2026 - 14:50 EDT

Update

We are actively working on the issue affecting White Label sites, My Credit Manager (MCM), and Identity Protection (IDP).

Customers may continue to experience intermittent issues with Identity Protection and Credit alerts. Our teams remain engaged in remediation efforts, and we will share additional updates as they become available.
Posted Jun 01, 2026 - 13:09 EDT

Update

Our team remains engaged in investigating the issue affecting White Label sites, My Credit Manager (MCM), and Identity Protection (IDP).

Customers may continue to experience intermittent issues with Identity Protection and Credit alerts. Additional updates will be provided as new information becomes available.
Posted Jun 01, 2026 - 12:04 EDT

Update

We are continuing to investigate the issue affecting White Label sites, My Credit Manager (MCM), and Identity Protection (IDP).

Customers may experience intermittent issues with Identity Protection and My Credit Manager alerts while our team works to identify and resolve the root cause. We will provide additional updates as more information becomes available.
Posted Jun 01, 2026 - 10:53 EDT

Investigating

We have been notified of a potential issue where users and clients may see a timeout and are investigating.
Posted Jun 01, 2026 - 10:16 EDT
This incident affected: My Credit Manager, Identity Protect, and Offers Engine.