Get in touch
Back
Resolved

High latency on authentication

Started 19 Feb at 03:52pm EST.

Experian
Created

We are currently experiencing intermittent latency issues with Experian. We have implemented a fallback solution and are actively working to bring systems back to full functionality.

Posted 19 Feb at 03:52pm EST.