Get in touch
Back
Degraded

Increased response times

Started 14 Feb at 11:37am EST, resolved 14 Feb at 12:49pm EST.

TransUnion Experian Equifax User API
Resolved

Latencies are back to normal and we are working to determine a root cause.

Posted 14 Feb at 12:49pm EST.
Created

We are experiencing higher than usual response times for some services. We are working hard to resolve this issue.

Posted 14 Feb at 11:37am EST.