Status
Get in touch
Back
Resolved
Authentication issues
Started 7 Feb at 10:59am EST.
Affected services
TransUnion
Experian
Equifax
Created
All KBA component clients were unable to authenticate.
Posted 7 Feb at 10:59am EST.