Get in touch
Back
Downtime

Systems Are Down

Started 6 Sep at 02:20pm EDT, resolved 6 Sep at 02:52pm EDT.

TransUnion Experian Equifax User API EFX Monitoring Alerts
Resolved

All Systems are back online

Posted 6 Sep at 02:52pm EDT.
Updated

Partial Restore to All Systems.

Posted 6 Sep at 02:36pm EDT.
Updated

We have identified the root cause are working to resolve this.

Posted 6 Sep at 02:27pm EDT.
Created

We are experiencing an outage across the board. Will update as we have more information

Posted 6 Sep at 02:20pm EDT.